about summary refs log tree commit diff
path: root/modules/nixos/hydra.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/nixos/hydra.nix
parent2024-04-18 (diff)
2024-04-21
Diffstat (limited to 'modules/nixos/hydra.nix')
-rw-r--r--modules/nixos/hydra.nix57
1 files changed, 0 insertions, 57 deletions
diff --git a/modules/nixos/hydra.nix b/modules/nixos/hydra.nix
deleted file mode 100644
index 85b89ab..0000000
--- a/modules/nixos/hydra.nix
+++ /dev/null
@@ -1,57 +0,0 @@
-{ config, lib, ... }:
-with lib;
-let
-  cfg = config.nixfiles.modules.hydra;
-in
-{
-  options.nixfiles.modules.hydra = {
-    enable = mkEnableOption "Hydra";
-
-    domain = mkOption {
-      description = "Domain name sans protocol scheme.";
-      type = with types; str;
-      default = "hydra.${config.networking.domain}";
-    };
-
-    port = mkOption {
-      description = "Port.";
-      type = with types; port;
-      default = 7754;
-    };
-  };
-
-  config = mkIf cfg.enable {
-    nixfiles.modules = {
-      nginx = {
-        enable = true;
-        upstreams.hydra.servers."127.0.0.1:${toString cfg.port}" = { };
-        virtualHosts.${cfg.domain}.locations."/".proxyPass = "http://hydra";
-      };
-      postgresql.enable = true;
-    };
-
-    services =
-      let
-        db = "hydra";
-      in
-      {
-        hydra = {
-          enable = true;
-          listenHost = "127.0.0.1";
-          inherit (cfg) port;
-          dbi = "dbi:Pg:dbname=${db};user=${db}";
-          hydraURL = cfg.domain;
-        };
-
-        postgresql = {
-          ensureDatabases = [ db ];
-          ensureUsers = [
-            {
-              name = db;
-              ensureDBOwnership = true;
-            }
-          ];
-        };
-      };
-  };
-}

Consider giving Nix/NixOS a try! <3