about summary refs log tree commit diff
path: root/modules/nixos/lxc.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2022-12-17 16:39:09 +0300
committerAzat Bahawi <azat@bahawi.net>2022-12-17 16:39:09 +0300
commit8f137c28230623259a964484adcf31fe00756594 (patch)
tree82bce6a13fda125087cf6d9dc80aa91d9230d6c4 /modules/nixos/lxc.nix
parent2022-11-20 (diff)
2022-12-17
Diffstat (limited to 'modules/nixos/lxc.nix')
-rw-r--r--modules/nixos/lxc.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/modules/nixos/lxc.nix b/modules/nixos/lxc.nix
new file mode 100644
index 0000000..4f7805f
--- /dev/null
+++ b/modules/nixos/lxc.nix
@@ -0,0 +1,16 @@
+{
+  config,
+  lib,
+  ...
+}:
+with lib; let
+  cfg = config.nixfiles.modules.lxc;
+in {
+  options.nixfiles.modules.lxc.enable =
+    mkEnableOption "LXC/LXD";
+
+  config = mkIf cfg.enable {
+    virtualisation.lxd.enable = true;
+    my.extraGroups = "lxd";
+  };
+}

Consider giving Nix/NixOS a try! <3