summaryrefslogtreecommitdiff
path: root/modules/nixos/matrix/dendrite.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-11-19 21:58:34 +0300
committerAzat Bahawi <azat@bahawi.net>2023-11-19 21:58:34 +0300
commitedf7cc355cb1f55a9301283ebec15e01dc4ffe62 (patch)
treebf7745040efadac618168b7a9a764acb482acb07 /modules/nixos/matrix/dendrite.nix
parent576d4d672d37e490bd5f8dfb4397909600ed68db (diff)
2023-11-19
Diffstat (limited to 'modules/nixos/matrix/dendrite.nix')
-rw-r--r--modules/nixos/matrix/dendrite.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/modules/nixos/matrix/dendrite.nix b/modules/nixos/matrix/dendrite.nix
index efeef3c..7528792 100644
--- a/modules/nixos/matrix/dendrite.nix
+++ b/modules/nixos/matrix/dendrite.nix
@@ -178,12 +178,12 @@ in {
};
in
concatStringsSep " " [
- "${pkgs.envsubst}/bin/envsubst"
+ (getExe pkgs.envsubst)
"-i ${(pkgs.formats.yaml {}).generate "dendrite.yaml" settings}"
"-o /run/dendrite/dendrite.yaml"
];
ExecStart = concatStringsSep " " [
- "${pkgs.dendrite}/bin/dendrite"
+ (getExe' pkgs.dendrite "dendrite")
"--config /run/dendrite/dendrite.yaml"
"--http-bind-address 127.0.0.1:${toString cfg.port}"
];