summaryrefslogtreecommitdiff
path: root/modules/nixos/mpd.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
committerAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
commit9a5427e3a0c0ccf2a82dc503149a26b23fbd6004 (patch)
treef28beec29deeea36038615a8fb98a810891940b5 /modules/nixos/mpd.nix
parent4ad0c3afc1f6caf0c3f05f99a15b22178f2c190b (diff)
2024-03-31
Diffstat (limited to 'modules/nixos/mpd.nix')
-rw-r--r--modules/nixos/mpd.nix28
1 files changed, 21 insertions, 7 deletions
diff --git a/modules/nixos/mpd.nix b/modules/nixos/mpd.nix
index 485cde3..7c3c821 100644
--- a/modules/nixos/mpd.nix
+++ b/modules/nixos/mpd.nix
@@ -4,16 +4,18 @@
pkgs,
...
}:
-with lib; let
+with lib;
+let
cfg = config.nixfiles.modules.mpd;
-in {
+in
+{
options.nixfiles.modules.mpd.enable = mkEnableOption "MPD and its clients.";
config = mkIf cfg.enable {
nixfiles.modules.sound.enable = true;
hm = {
- home.packages = with pkgs; [mpc_cli];
+ home.packages = with pkgs; [ mpc_cli ];
services.mpd = {
enable = true;
@@ -170,19 +172,31 @@ in {
}
{
key = "J";
- command = ["select_item" "scroll_down"];
+ command = [
+ "select_item"
+ "scroll_down"
+ ];
}
{
key = "K";
- command = ["select_item" "scroll_up"];
+ command = [
+ "select_item"
+ "scroll_up"
+ ];
}
{
key = "h";
- command = ["previous_column" "master_screen"];
+ command = [
+ "previous_column"
+ "master_screen"
+ ];
}
{
key = "l";
- command = ["next_column" "slave_screen"];
+ command = [
+ "next_column"
+ "slave_screen"
+ ];
}
{
key = "g";