summaryrefslogtreecommitdiff
path: root/modules/nixos/profiles/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/nixos/profiles/default.nix
parent9ac64328603d44bd272175942d3ea3eaadcabd04 (diff)
2024-04-21
Diffstat (limited to 'modules/nixos/profiles/default.nix')
-rw-r--r--modules/nixos/profiles/default.nix37
1 files changed, 0 insertions, 37 deletions
diff --git a/modules/nixos/profiles/default.nix b/modules/nixos/profiles/default.nix
deleted file mode 100644
index 93c46e3..0000000
--- a/modules/nixos/profiles/default.nix
+++ /dev/null
@@ -1,37 +0,0 @@
-{
- config,
- lib,
- pkgs,
- ...
-}:
-with lib;
-let
- cfg = config.nixfiles.modules.profiles.default;
-in
-{
- imports = [
- ./dev
- ./headful.nix
- ./headless.nix
- ];
-
- config = mkIf cfg.enable {
- ark.directories = [ "/var/log" ];
-
- programs.less = {
- enable = true;
- envVariables.LESSHISTFILE = "-";
- };
-
- environment.systemPackages = with pkgs; [
- cryptsetup
- lshw
- lsof
- pciutils
- psmisc
- sysstat
- usbutils
- util-linux
- ];
- };
-}