summaryrefslogtreecommitdiff
path: root/modules/nixos/prometheus.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/nixos/prometheus.nix
parent9ac64328603d44bd272175942d3ea3eaadcabd04 (diff)
2024-04-21
Diffstat (limited to 'modules/nixos/prometheus.nix')
-rw-r--r--modules/nixos/prometheus.nix53
1 files changed, 0 insertions, 53 deletions
diff --git a/modules/nixos/prometheus.nix b/modules/nixos/prometheus.nix
deleted file mode 100644
index 9f28cd5..0000000
--- a/modules/nixos/prometheus.nix
+++ /dev/null
@@ -1,53 +0,0 @@
-{
- config,
- lib,
- libNginx,
- ...
-}:
-with lib;
-let
- cfg = config.nixfiles.modules.prometheus;
-in
-{
- options.nixfiles.modules.prometheus = {
- enable = mkEnableOption "Prometheus";
-
- port = mkOption {
- description = "Port.";
- type = with types; port;
- default = 30111;
- };
-
- domain = mkOption {
- description = "Domain name sans protocol scheme.";
- type = with types; str;
- default = "prometheus.${config.networking.domain}";
- };
- };
-
- config = mkIf cfg.enable {
- nixfiles.modules.nginx = with cfg; {
- enable = true;
- upstreams.prometheus.servers."127.0.0.1:${toString cfg.port}" = { };
- virtualHosts.${domain} = {
- locations."/".proxyPass = "http://prometheus";
- extraConfig = libNginx.config.internalOnly;
- };
- };
-
- services.prometheus = with cfg; {
- enable = true;
- enableReload = true;
-
- listenAddress = "127.0.0.1";
- inherit port;
-
- extraFlags = [
- "--web.external-url=https://${domain}"
- "--storage.tsdb.retention.size=50GB"
- "--storage.tsdb.retention.time=1y"
- "--storage.tsdb.wal-compression"
- ];
- };
- };
-}