summaryrefslogtreecommitdiff
path: root/modules/nixos/promtail.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-11-25 18:09:05 +0300
committerAzat Bahawi <azat@bahawi.net>2023-11-25 18:09:05 +0300
commite2cc46b37e33643cf3dd017adb8a009bf143e246 (patch)
tree86f24ea544e9ed75bf8736c951a09dfdb2219f5d /modules/nixos/promtail.nix
parent67b82386d8ad8ae3eea5083bd22809f6192d92a8 (diff)
2023-11-25
Diffstat (limited to 'modules/nixos/promtail.nix')
-rw-r--r--modules/nixos/promtail.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/modules/nixos/promtail.nix b/modules/nixos/promtail.nix
index 157eb72..28dc897 100644
--- a/modules/nixos/promtail.nix
+++ b/modules/nixos/promtail.nix
@@ -47,15 +47,15 @@ in {
clients = [
{
url = "${cfg.loki.url}/loki/api/v1/push";
- batchwait = "15s";
- batchsize = 1000000;
+ batchwait = "30s";
+ batchsize = 100000;
external_labels.host_id = config.networking.hostId;
}
];
positions = {
filename = "/tmp/positions.yaml";
- sync_period = "15s";
+ sync_period = "30s";
ignore_invalid_yaml = true;
};
@@ -73,10 +73,10 @@ in {
then substring 1 (stringLength label - 1) label
else label;
}) [
- # Derived from systemd.journal fields[1][2].
+ # Derived from systemd.journal fields[1].
#
+ # [1]: https://github.com/coreos/go-systemd/blob/main/sdjournal/journal.go#L335
# [1]: https://www.freedesktop.org/software/systemd/man/systemd.journal-fields.html
- # [2]: https://github.com/coreos/go-systemd/blob/main/sdjournal/journal.go#L335
"MESSAGE"
# "MESSAGE_ID"