summaryrefslogtreecommitdiff
path: root/modules/nixos/rtorrent.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-11-19 21:58:34 +0300
committerAzat Bahawi <azat@bahawi.net>2023-11-19 21:58:34 +0300
commitedf7cc355cb1f55a9301283ebec15e01dc4ffe62 (patch)
treebf7745040efadac618168b7a9a764acb482acb07 /modules/nixos/rtorrent.nix
parent576d4d672d37e490bd5f8dfb4397909600ed68db (diff)
2023-11-19
Diffstat (limited to 'modules/nixos/rtorrent.nix')
-rw-r--r--modules/nixos/rtorrent.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/modules/nixos/rtorrent.nix b/modules/nixos/rtorrent.nix
index 5d2dba5..847f12d 100644
--- a/modules/nixos/rtorrent.nix
+++ b/modules/nixos/rtorrent.nix
@@ -63,7 +63,8 @@ in {
mv -fv "$leech_path" "$seed_path"
'';
};
- in "${pkg}/bin/move-completed";
+ in
+ getExe pkg;
in
pkgs.writeText "rtorrent.rc" ''
method.insert = cfg.leech, private|const|string, (cat, "${leechDir}")
@@ -143,7 +144,7 @@ in {
logDir
];
ExecStart = concatStringsSep " " [
- "${pkgs.rtorrent}/bin/rtorrent"
+ (getExe pkgs.rtorrent)
"-n"
"-o system.daemon.set=true"
"-o network.bind_address.set=0.0.0.0"
@@ -245,7 +246,7 @@ in {
Group = group;
ExecStart = concatStringsSep " " [
- "${pkg}/bin/flood"
+ (getExe pkg)
"--allowedpath=${baseDir}"
"--baseuri=/"
"--rundir=${baseDir}/flood"