summaryrefslogtreecommitdiff
path: root/modules/nixos/throttled.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-09-30 15:21:49 +0300
committerAzat Bahawi <azat@bahawi.net>2023-09-30 15:21:49 +0300
commit0221d5913ea26fde9493dadfbb265f2ff103124f (patch)
tree29258145f96ffd9bcf5e39f6a1e1e7c4cab57355 /modules/nixos/throttled.nix
parent1516209f857dd328828dd3c5da7f85d8af27a7ec (diff)
2023-09-30
Diffstat (limited to 'modules/nixos/throttled.nix')
-rw-r--r--modules/nixos/throttled.nix14
1 files changed, 1 insertions, 13 deletions
diff --git a/modules/nixos/throttled.nix b/modules/nixos/throttled.nix
index f182ee1..a84fd27 100644
--- a/modules/nixos/throttled.nix
+++ b/modules/nixos/throttled.nix
@@ -1,7 +1,6 @@
{
config,
lib,
- pkgs,
...
}:
with lib; let
@@ -10,8 +9,7 @@ in {
options.nixfiles.modules.throttled.enable = mkEnableOption "Throttled";
config = mkIf cfg.enable {
- # Disable the module we are trying to "override".
- services.throttled.enable = mkForce false;
+ services.throttled.enable = true;
environment.etc."throttled.conf".text = ''
[GENERAL]
@@ -105,15 +103,5 @@ in {
# # CPU cache max current (A)
# CACHE:
'';
-
- systemd.services.throttled = {
- description = "Stop Intel throttling";
- serviceConfig = {
- Type = "simple";
- ExecStart = "${pkgs.throttled}/opt/throttled/throttled.py";
- };
- environment.PYTHONUNBUFFERED = "1";
- wantedBy = ["multi-user.target"];
- };
};
}