summaryrefslogtreecommitdiff
path: root/modules/nixos/unbound.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-03-08 21:30:37 +0300
committerAzat Bahawi <azat@bahawi.net>2024-03-08 21:30:37 +0300
commit04be52d7b75eb62203a3af8d85e36e3584123f90 (patch)
tree5ad22924998c10c45834eadae6c0498a3ac4be1b /modules/nixos/unbound.nix
parent037ef27243eab47d6e1c29f231c248dc2aa4966e (diff)
2024-03-08
Diffstat (limited to 'modules/nixos/unbound.nix')
-rw-r--r--modules/nixos/unbound.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/modules/nixos/unbound.nix b/modules/nixos/unbound.nix
index e6cad81..5aaf104 100644
--- a/modules/nixos/unbound.nix
+++ b/modules/nixos/unbound.nix
@@ -35,6 +35,7 @@ in {
withTFO = true;
};
+ checkconf = false;
settings = {
server = {
interface = with this.wireguard; [
@@ -164,9 +165,10 @@ in {
name = "unbound-adblock-update";
runtimeInputs = [pkgs.curl package];
text = ''
- curl -s \
- "https://pgl.yoyo.org/adservers/serverlist.php?hostformat=unbound&showintro=0&mimetype=plaintext" \
- >${adblock-conf}
+ curl \
+ -s \
+ -o ${adblock-conf} \
+ "https://raw.githubusercontent.com/hagezi/dns-blocklists/main/unbound/multi.blacklist.conf"
if [[ -f "${localControlSocketPath}" ]]; then
unbound-control reload
@@ -179,6 +181,7 @@ in {
timers.unbound-adblock-update = {
requires = ["network-online.target"];
+ after = ["network-online.target"];
timerConfig = {
OnCalendar = "daily";
Persistent = true;