summaryrefslogtreecommitdiff
path: root/modules/nixos/unbound.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-05-21 23:10:32 +0300
committerAzat Bahawi <azat@bahawi.net>2023-05-21 23:10:32 +0300
commitb07e10139c88d6060e57ca52b2dc12b17b53ac82 (patch)
tree5b5cddc2f47bddb8e8914aa66ae18d52cd519965 /modules/nixos/unbound.nix
parent8f7371998f813857f25afef4160075665f924ab7 (diff)
2023-05-21
Diffstat (limited to 'modules/nixos/unbound.nix')
-rw-r--r--modules/nixos/unbound.nix17
1 files changed, 16 insertions, 1 deletions
diff --git a/modules/nixos/unbound.nix b/modules/nixos/unbound.nix
index 7805b02..c9d45f2 100644
--- a/modules/nixos/unbound.nix
+++ b/modules/nixos/unbound.nix
@@ -24,7 +24,22 @@ in {
mkIf cfg.enable {
ark.directories = [config.services.unbound.stateDir];
- nixfiles.modules.redis.enable = true;
+ nixfiles.modules = {
+ redis.enable = true;
+
+ promtail.filters = [
+ {
+ match = {
+ # Should be fixed[1] in the next release.
+ #
+ # [1]: https://github.com/NLnetLabs/unbound/commit/d7e776114114c16816570e48ab3a27eedc401a0e
+ selector = ''{syslog_identifier="unbound"} |~ ".*could not SSL_read crypto.*"'';
+ action = "drop";
+ drop_counter_reason = "noisy_error";
+ };
+ }
+ ];
+ };
services = {
unbound = {