summaryrefslogtreecommitdiff
path: root/modules/nixos/wayland.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
committerAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
commit9a5427e3a0c0ccf2a82dc503149a26b23fbd6004 (patch)
treef28beec29deeea36038615a8fb98a810891940b5 /modules/nixos/wayland.nix
parent4ad0c3afc1f6caf0c3f05f99a15b22178f2c190b (diff)
2024-03-31
Diffstat (limited to 'modules/nixos/wayland.nix')
-rw-r--r--modules/nixos/wayland.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/modules/nixos/wayland.nix b/modules/nixos/wayland.nix
index b64ab32..e3dba79 100644
--- a/modules/nixos/wayland.nix
+++ b/modules/nixos/wayland.nix
@@ -4,12 +4,16 @@
pkgs,
...
}:
-with lib; let
+with lib;
+let
cfg = config.nixfiles.modules.wayland;
-in {
+in
+{
options.nixfiles.modules.wayland.enable = mkEnableOption "Wayland";
config = mkIf cfg.enable {
- hm.home.packages = with pkgs; [wl-clipboard];
+ nixfiles.modules.foot.enable = true;
+
+ hm.home.packages = with pkgs; [ wl-clipboard ];
};
}