summaryrefslogtreecommitdiff
path: root/modules/nsd.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-05-05 14:28:31 +0300
committerAzat Bahawi <azat@bahawi.net>2024-05-05 14:28:31 +0300
commit389becf9700d3dee7f09073ce4d235fc7c30b5c8 (patch)
tree3db9d75bd5275614fc904184c97b3133f38bc3d0 /modules/nsd.nix
parent3cd3233f7eaf2a8a715d587820d6d4577a24d958 (diff)
2024-05-05
Diffstat (limited to 'modules/nsd.nix')
-rw-r--r--modules/nsd.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/modules/nsd.nix b/modules/nsd.nix
index f44a2a0..9adc084 100644
--- a/modules/nsd.nix
+++ b/modules/nsd.nix
@@ -225,5 +225,15 @@ in
allowedTCPPorts = [ 53 ];
allowedUDPPorts = allowedTCPPorts;
};
+
+ topology = with cfg; {
+ nodes.${this.hostname}.services.nsd = {
+ name = "NSD";
+ icon = "${inputs.homelab-svg-assets}/assets/unbound.svg";
+ details.listen.text = concatMapStringsSep "\n" (i: "${i}:53") (
+ filter (i: i != "127.0.0.1" && i != "::1") config.services.nsd.interfaces
+ );
+ };
+ };
};
}