summaryrefslogtreecommitdiff
path: root/modules/profiles/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/profiles/default.nix
parent9ac64328603d44bd272175942d3ea3eaadcabd04 (diff)
2024-04-21
Diffstat (limited to 'modules/profiles/default.nix')
-rw-r--r--modules/profiles/default.nix62
1 files changed, 62 insertions, 0 deletions
diff --git a/modules/profiles/default.nix b/modules/profiles/default.nix
new file mode 100644
index 0000000..e3002b0
--- /dev/null
+++ b/modules/profiles/default.nix
@@ -0,0 +1,62 @@
+{
+ config,
+ lib,
+ pkgs,
+ this,
+ ...
+}:
+with lib;
+let
+ cfg = config.nixfiles.modules.profiles.default;
+in
+{
+ imports = attrValues (modulesIn ./.);
+
+ options.nixfiles.modules.profiles.default.enable =
+ mkEnableOption "The most default profile of them all."
+ // {
+ default = true;
+ };
+
+ config = mkIf cfg.enable {
+ assertions = [
+ {
+ assertion = !(with this; isHeadless && isHeadful);
+ message = ''
+ The configuration cannot be both "headful" and "headless" at the same
+ time.
+ '';
+ }
+ ];
+
+ ark.directories = [ "/var/log" ];
+
+ nixfiles.modules = {
+ bat.enable = true;
+ eza.enable = true;
+ htop.enable = true;
+ tmux.enable = true;
+ vim.enable = true;
+ };
+
+ programs.less = {
+ enable = true;
+ envVariables.LESSHISTFILE = "-";
+ };
+
+ time.timeZone = "Europe/Moscow";
+
+ environment.systemPackages = with pkgs; [
+ cryptsetup
+ file
+ lshw
+ lsof
+ pciutils
+ psmisc
+ sysstat
+ tree
+ usbutils
+ util-linux
+ ];
+ };
+}