summaryrefslogtreecommitdiff
path: root/modules/vim/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-06-24 11:10:21 +0300
committerAzat Bahawi <azat@bahawi.net>2024-06-24 11:10:21 +0300
commit75918debfd7245d90478f882b0323a705ab3c7be (patch)
tree26b8f0ab5a3e4d7c61963fa96d57250e5ddc9a7d /modules/vim/default.nix
parent9eb603b80a3d823acfc20c42f777ea26436ca137 (diff)
2024-06-24
Diffstat (limited to 'modules/vim/default.nix')
-rw-r--r--modules/vim/default.nix71
1 files changed, 0 insertions, 71 deletions
diff --git a/modules/vim/default.nix b/modules/vim/default.nix
deleted file mode 100644
index 94cc7af..0000000
--- a/modules/vim/default.nix
+++ /dev/null
@@ -1,71 +0,0 @@
-{
- config,
- lib,
- pkgs,
- ...
-}:
-with lib;
-let
- cfg = config.nixfiles.modules.vim;
-in
-{
- options.nixfiles.modules.vim = {
- enable = mkEnableOption "Vim";
-
- rc = mkOption {
- type = types.str;
- default = readFile ./rc.vim;
- description = "Configuration file.";
- };
-
- plugins = mkOption {
- type = with types; listOf package;
- default = with pkgs.vimPlugins; [
- editorconfig-vim
- vim-eunuch
- vim-nix
- vim-sensible
- vim-sleuth
- vim-surround
- vim-unimpaired
- ];
- description = "Plugins.";
- };
- };
-
- config = mkIf cfg.enable {
- hm.stylix.targets.vim.enable = false;
-
- programs.vim.package =
- (pkgs.vim-full.override {
- cscopeSupport = false;
- darwinSupport = false;
- features = "normal";
- guiSupport = "gtk3";
- luaSupport = false;
- multibyteSupport = false;
- netbeansSupport = false;
- nlsSupport = false;
- perlSupport = false;
- pythonSupport = false;
- rubySupport = false;
- tclSupport = false;
- ximSupport = false;
- }).customize
- {
- name = "vim";
- vimrcConfig = with cfg; {
- customRC = rc;
- packages.myVimPackage.start = plugins;
- };
- };
-
- environment = {
- systemPackages = [ config.programs.vim.package ];
- variables = rec {
- EDITOR = "vim";
- VISUAL = EDITOR;
- };
- };
- };
-}