summaryrefslogtreecommitdiff
path: root/modules/wayland.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/wayland.nix
parent9ac64328603d44bd272175942d3ea3eaadcabd04 (diff)
2024-04-21
Diffstat (limited to 'modules/wayland.nix')
-rw-r--r--modules/wayland.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/modules/wayland.nix b/modules/wayland.nix
new file mode 100644
index 0000000..e3dba79
--- /dev/null
+++ b/modules/wayland.nix
@@ -0,0 +1,19 @@
+{
+ config,
+ lib,
+ pkgs,
+ ...
+}:
+with lib;
+let
+ cfg = config.nixfiles.modules.wayland;
+in
+{
+ options.nixfiles.modules.wayland.enable = mkEnableOption "Wayland";
+
+ config = mkIf cfg.enable {
+ nixfiles.modules.foot.enable = true;
+
+ hm.home.packages = with pkgs; [ wl-clipboard ];
+ };
+}