about summary refs log tree commit diff
path: root/modules/x11.nix
diff options
context:
space:
mode:
authorazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
committerazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
commit59180328cda59817d71cd58c8f48ead047375064 (patch)
tree2cdd7d1bfa309839ef624c19daf283f510aacf69 /modules/x11.nix
parent2025-02-05 (diff)
2025-02-17
Diffstat (limited to 'modules/x11.nix')
-rw-r--r--modules/x11.nix21
1 files changed, 10 insertions, 11 deletions
diff --git a/modules/x11.nix b/modules/x11.nix
index 4edab6b..32cc781 100644
--- a/modules/x11.nix
+++ b/modules/x11.nix
@@ -4,14 +4,13 @@
   pkgs,
   ...
 }:
-with lib;
 let
   cfg = config.nixfiles.modules.x11;
 in
 {
-  options.nixfiles.modules.x11.enable = mkEnableOption "X11";
+  options.nixfiles.modules.x11.enable = lib.mkEnableOption "X11";
 
-  config = mkIf cfg.enable {
+  config = lib.mkIf cfg.enable {
     hm = {
       home = {
         sessionVariables = {
@@ -21,16 +20,16 @@ in
           XCOMPOSECACHE = "${config.dirs.cache}/libx11/compose";
         };
 
-        packages = with pkgs; [ xclip ];
+        packages = [ pkgs.xclip ];
       };
 
       xresources.properties = {
-        "Xft.antialias" = mkDefault 1;
-        "Xft.autohint" = mkDefault 0;
-        "Xft.hinting" = mkDefault 1;
-        "Xft.hintstyle" = mkDefault "hintslight";
-        "Xft.lcdfilter" = mkDefault "lcddefault";
-        "Xft.rgba" = mkDefault "rgb";
+        "Xft.antialias" = lib.mkDefault 1;
+        "Xft.autohint" = lib.mkDefault 0;
+        "Xft.hinting" = lib.mkDefault 1;
+        "Xft.hintstyle" = lib.mkDefault "hintslight";
+        "Xft.lcdfilter" = lib.mkDefault "lcddefault";
+        "Xft.rgba" = lib.mkDefault "rgb";
       };
 
       services.xsettingsd = {
@@ -59,7 +58,7 @@ in
     services.xserver = {
       enable = true;
 
-      tty = mkDefault 1;
+      tty = lib.mkDefault 1;
 
       autoRepeatDelay = 200;
       autoRepeatInterval = 50;

Consider giving Nix/NixOS a try! <3