summaryrefslogtreecommitdiff
path: root/nixosConfigurations/eonwe/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-01-05 04:22:04 +0300
committerAzat Bahawi <azat@bahawi.net>2023-01-05 04:22:04 +0300
commit5e81e4814d6da25ce8531baf0bc2d23da7fc26b3 (patch)
treecd887f80d9f98d42db556b4a42bcb8d5faa91c84 /nixosConfigurations/eonwe/default.nix
parent313e18cb6119d4b03580d8d34fbec0c78bca872c (diff)
2023-01-05
Diffstat (limited to 'nixosConfigurations/eonwe/default.nix')
-rw-r--r--nixosConfigurations/eonwe/default.nix49
1 files changed, 37 insertions, 12 deletions
diff --git a/nixosConfigurations/eonwe/default.nix b/nixosConfigurations/eonwe/default.nix
index a867837..f07aad3 100644
--- a/nixosConfigurations/eonwe/default.nix
+++ b/nixosConfigurations/eonwe/default.nix
@@ -15,6 +15,7 @@ with lib; {
games = {
lutris.enable = true;
+ minecraft.client.enable = true;
steam.enable = true;
};
android.enable = true;
@@ -25,8 +26,12 @@ with lib; {
};
hm.programs = {
- firefox.profiles.default.settings."media.ffmpeg.vaapi.enabled" = true;
+ # NOTE This produces very poor performance even though RX 6750 XT should
+ # handle VA-API hardware decoding for all major formats (including AV1) just
+ # fine.
+ firefox.profiles.default.settings."media.ffmpeg.vaapi.enabled" = false;
+ # Mostly just placebo. :^)
mpv.config = {
hwdec = "vdpau";
vo = "gpu";
@@ -34,6 +39,15 @@ with lib; {
};
};
+ # Usually stuff that is going to be compiled on this machine is going to have
+ # parallelisation support enabled, so we will make sure that all cores are
+ # utilised and limit the job queue to one.
+ nix.extraOptions = ''
+ keep-going = true
+ max-jobs = 1
+ cores = 32
+ '';
+
boot = {
# Silence benign MCE errors:
# ```
@@ -43,16 +57,26 @@ with lib; {
# ```
kernelParams = ["mce=nobootlog"];
- initrd.availableKernelModules = [
- "ahci"
- "nvme"
- "sd_mod"
- "usb_storage"
- "usbhid"
- "xhci_pci"
- ];
+ # The boot drive is Samsung SSD 980 PRO 2TB.
+ initrd.kernelModules = ["nvme"];
};
+ # TODO Immutable `/' shire on ZFS datasets and snapshots.
+ #
+ # Opt-in:
+ # - /etc/NetworkManager
+ # - /etc/ssh
+ # - /home
+ # - /var/lib/bluetooth
+ # - /var/lib/iwd
+ # - /var/lib/log
+ #
+ # Investigate:
+ # - /var/lib/NetworkManager
+ # - /var/lib/cni
+ # - /var/lib/containers
+ # - /var/lib/qemu
+
fileSystems = {
"/boot" = {
device = "/dev/disk/by-uuid/FF1E-9CFD";
@@ -66,7 +90,8 @@ with lib; {
};
};
- # No swap space is declared here because the system already has 128Gb of RAM.
- # I didn't manage to even hit 100Gb mark even when running large
- # computations/compiling something big.
+ # No swap space is declared here because the system already has 128Gb of RAM. :^)
+ # I've only manage to hit around 100Gb mark when running large
+ # computations/compiling something big. Pretty sure that a hefty chunk of it
+ # was just residual cache and it wouldn't make me get to OOM situations.
}