summaryrefslogtreecommitdiff
path: root/nixosConfigurations/eonwe/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-06-21 01:02:13 +0300
committerAzat Bahawi <azat@bahawi.net>2023-06-21 01:02:13 +0300
commit8e048c489aed8b8b27695694e8d020358a081bd7 (patch)
tree2e6d24dd3d8ce2e8d22116683f9e882f8a58e183 /nixosConfigurations/eonwe/default.nix
parent2ed2b884c50f25bf757113c9630b12147d3f9b18 (diff)
2023-06-21
Diffstat (limited to 'nixosConfigurations/eonwe/default.nix')
-rw-r--r--nixosConfigurations/eonwe/default.nix20
1 files changed, 8 insertions, 12 deletions
diff --git a/nixosConfigurations/eonwe/default.nix b/nixosConfigurations/eonwe/default.nix
index 5e12cc6..677006a 100644
--- a/nixosConfigurations/eonwe/default.nix
+++ b/nixosConfigurations/eonwe/default.nix
@@ -26,13 +26,10 @@ with lib; {
qutebrowser.enable = true;
mpd.enable = true;
ipfs.enable = true;
-
- common.nix.allowedUnfreePackages = ["burpsuite"];
};
hm = {
home.packages = with pkgs; [
- burpsuite
gzdoom
kdenlive
obs-studio
@@ -41,22 +38,16 @@ with lib; {
radeontop
vcmi
vial
- whatweb
+ xonotic
];
programs = {
beets.settings.directory = mkForce "/mnt/udata/music";
- # NOTE This produces very poor performance even though RX 6750 XT should
- # handle VA-API hardware decoding for all major formats (including AV1) just
- # fine.
- firefox.profiles.default.settings."media.ffmpeg.vaapi.enabled" = false;
-
- # Mostly just placebo. :^)
mpv.config = {
- hwdec = "vdpau";
- vo = "gpu";
+ gpu-api = "vulkan";
profile = "gpu-hq";
+ vo = "gpu-next";
};
};
@@ -73,6 +64,11 @@ with lib; {
};
};
+ openssh.settings = {
+ KbdInteractiveAuthentication = mkForce true;
+ PasswordAuthentication = mkForce true;
+ };
+
udev.packages = with pkgs; [vial];
};