summaryrefslogtreecommitdiff
path: root/nixosConfigurations/eonwe/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-02-03 00:38:33 +0300
committerAzat Bahawi <azat@bahawi.net>2023-02-03 00:38:33 +0300
commited775a06b6fee8788330fa07f1b9d26d5d2c4fcd (patch)
treeefaba6e97da77a2668c366544f76dbd6ae0a9ac6 /nixosConfigurations/eonwe/default.nix
parenta91c2015ba96053a65a3cc0937752976e7addaef (diff)
2023-02-03
Diffstat (limited to 'nixosConfigurations/eonwe/default.nix')
-rw-r--r--nixosConfigurations/eonwe/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/nixosConfigurations/eonwe/default.nix b/nixosConfigurations/eonwe/default.nix
index 3bd7230..97dd1d1 100644
--- a/nixosConfigurations/eonwe/default.nix
+++ b/nixosConfigurations/eonwe/default.nix
@@ -101,6 +101,10 @@ with lib; {
# -o mountpoint=legacy
# nixos/root/nix
# ```
+ #
+ # As for Podman support over ZFS[1]. We wait.
+ #
+ # [1]: https://github.com/openzfs/zfs/pull/14070#issuecomment-1309116666
fileSystems = {
"/" = {
device = "none";
@@ -135,6 +139,18 @@ with lib; {
depends = [config.ark.path];
neededForBoot = true;
};
+
+ # "/home/${my.username}/.local/share/containers/storage" = {
+ # device = "nixos/containers/${my.username}/storage";
+ # fsType = "zfs";
+ # options = ["noatime"];
+ # };
+
+ # "/var/lib/containers/storage" = {
+ # device = "nixos/containers/root/storage";
+ # fsType = "zfs";
+ # options = ["noatime"];
+ # };
};
# No swap space is declared here because the system already has 128Gb of RAM. :^)