summaryrefslogtreecommitdiff
path: root/nixosConfigurations/manwe/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-03-11 12:51:58 +0300
committerAzat Bahawi <azat@bahawi.net>2023-03-11 12:51:58 +0300
commit0ef23d4501592a192ba020a2ac34abb1a3d8fc5e (patch)
tree17f0377d71f7c645acf8502c769a0ade76cbc901 /nixosConfigurations/manwe/default.nix
parente40f7d991353ad70984afdf67b25c049190c56bd (diff)
2023-03-11
Diffstat (limited to 'nixosConfigurations/manwe/default.nix')
-rw-r--r--nixosConfigurations/manwe/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/nixosConfigurations/manwe/default.nix b/nixosConfigurations/manwe/default.nix
index 12d929e..a47cd88 100644
--- a/nixosConfigurations/manwe/default.nix
+++ b/nixosConfigurations/manwe/default.nix
@@ -1,5 +1,6 @@
{
config,
+ inputs,
lib,
...
}:
@@ -34,6 +35,7 @@ with lib; {
enable = true;
domain = my.domain.azahi;
};
+ murmur.enable = true;
radicale.enable = true;
rss-bridge.enable = true;
shadowsocks.enable = true;
@@ -44,6 +46,35 @@ with lib; {
vaultwarden.enable = true;
};
+ # To play old LAN games with the boys.
+ secrets."wireguard-private-key-70".file = "${inputs.self}/secrets/wireguard-private-key-70";
+ networking = mkIf config.nixfiles.modules.wireguard.server.enable {
+ wireguard.interfaces.wg70 = {
+ ips = ["10.70.0.1/16"];
+ listenPort = 7070;
+ privateKeyFile = config.secrets."wireguard-private-key-70".path;
+ peers = [
+ {
+ publicKey = "@PUBLIC_KEY@";
+ allowedIPs = ["10.70.1.1/32"];
+ }
+ {
+ publicKey = "@PUBLIC_KEY@";
+ allowedIPs = ["10.70.1.2/32"];
+ }
+ {
+ publicKey = "@PUBLIC_KEY@";
+ allowedIPs = ["10.70.1.3/32"];
+ }
+ {
+ publicKey = "@PUBLIC_KEY@";
+ allowedIPs = ["10.70.1.4/32"];
+ }
+ ];
+ };
+ firewall.allowedUDPPorts = [7070];
+ };
+
boot = {
loader.grub = {
enable = true;