summaryrefslogtreecommitdiff
path: root/nixosConfigurations/manwe/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
committerAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
commit9a5427e3a0c0ccf2a82dc503149a26b23fbd6004 (patch)
treef28beec29deeea36038615a8fb98a810891940b5 /nixosConfigurations/manwe/default.nix
parent4ad0c3afc1f6caf0c3f05f99a15b22178f2c190b (diff)
2024-03-31
Diffstat (limited to 'nixosConfigurations/manwe/default.nix')
-rw-r--r--nixosConfigurations/manwe/default.nix17
1 files changed, 5 insertions, 12 deletions
diff --git a/nixosConfigurations/manwe/default.nix b/nixosConfigurations/manwe/default.nix
index 5a2fffd..e7edbf9 100644
--- a/nixosConfigurations/manwe/default.nix
+++ b/nixosConfigurations/manwe/default.nix
@@ -1,9 +1,6 @@
+{ config, lib, ... }:
+with lib;
{
- config,
- lib,
- ...
-}:
-with lib; {
imports = [
./mailserver
./webserver.nix
@@ -64,21 +61,17 @@ with lib; {
"/" = {
device = "/dev/sda2";
fsType = "xfs";
- options = ["noatime"];
+ options = [ "noatime" ];
};
"/boot" = {
device = "/dev/sda1";
fsType = "xfs";
- options = ["noatime"];
+ options = [ "noatime" ];
};
};
- swapDevices = [
- {
- device = "/dev/sda3";
- }
- ];
+ swapDevices = [ { device = "/dev/sda3"; } ];
zramSwap = {
enable = true;