summaryrefslogtreecommitdiff
path: root/nixosConfigurations/manwe/webserver.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-05-06 18:55:06 +0300
committerAzat Bahawi <azat@bahawi.net>2023-05-06 18:55:06 +0300
commit8f7371998f813857f25afef4160075665f924ab7 (patch)
tree7bffc723cbed32ab8aacae2feaf60de039bd3ff3 /nixosConfigurations/manwe/webserver.nix
parent8d48aa19f45d621d0ce234c81d3c930cb5b05eb5 (diff)
2023-05-06
Diffstat (limited to 'nixosConfigurations/manwe/webserver.nix')
-rw-r--r--nixosConfigurations/manwe/webserver.nix35
1 files changed, 19 insertions, 16 deletions
diff --git a/nixosConfigurations/manwe/webserver.nix b/nixosConfigurations/manwe/webserver.nix
index 4dded7e..f07d545 100644
--- a/nixosConfigurations/manwe/webserver.nix
+++ b/nixosConfigurations/manwe/webserver.nix
@@ -4,20 +4,23 @@
...
}:
with lib; {
- nixfiles.modules.nginx.virtualHosts = with my.domain;
- {
- ${shire}.locations."/".return = "301 https://www.youtube.com/watch?v=dQw4w9WgXcQ";
- "git.${shire}".locations."/".return = "301 https://git.${azahi}";
- "bitwarden.${shire}".locations."/".return = "301 https://vaultwarden.${shire}";
- ${azahi} = {
- serverAliases = ["frodo.${gondor}" "frodo.${rohan}"];
- locations."/".root = inputs.azahi-cc;
- };
- }
- // (let
- frodo = "301 https://frodo.";
- in {
- ${gondor}.locations."/".return = concatStrings [frodo gondor];
- ${rohan}.locations."/".return = concatStrings [frodo rohan];
- });
+ nixfiles.modules.nginx = {
+ enable = true;
+ virtualHosts = with my.domain;
+ {
+ ${shire}.locations."/".return = "301 https://www.youtube.com/watch?v=dQw4w9WgXcQ";
+ "git.${shire}".locations."/".return = "301 https://git.${azahi}";
+ "bitwarden.${shire}".locations."/".return = "301 https://vaultwarden.${shire}";
+ ${azahi} = {
+ serverAliases = ["frodo.${gondor}" "frodo.${rohan}"];
+ locations."/".root = inputs.azahi-cc;
+ };
+ }
+ // (let
+ frodo = "301 https://frodo.";
+ in {
+ ${gondor}.locations."/".return = concatStrings [frodo gondor];
+ ${rohan}.locations."/".return = concatStrings [frodo rohan];
+ });
+ };
}