summaryrefslogtreecommitdiff
path: root/nixosConfigurations/melian/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-01-05 04:22:04 +0300
committerAzat Bahawi <azat@bahawi.net>2023-01-05 04:22:04 +0300
commit5e81e4814d6da25ce8531baf0bc2d23da7fc26b3 (patch)
treecd887f80d9f98d42db556b4a42bcb8d5faa91c84 /nixosConfigurations/melian/default.nix
parent313e18cb6119d4b03580d8d34fbec0c78bca872c (diff)
2023-01-05
Diffstat (limited to 'nixosConfigurations/melian/default.nix')
-rw-r--r--nixosConfigurations/melian/default.nix34
1 files changed, 13 insertions, 21 deletions
diff --git a/nixosConfigurations/melian/default.nix b/nixosConfigurations/melian/default.nix
index 3ba854c..d7563d7 100644
--- a/nixosConfigurations/melian/default.nix
+++ b/nixosConfigurations/melian/default.nix
@@ -13,6 +13,8 @@ with lib; {
bluetooth.enable = true;
throttled.enable = true;
+
+ android.enable = true;
};
hardware.trackpoint = {
@@ -26,13 +28,17 @@ with lib; {
in {
enable = true;
- # This fixes an issue with not being able to suspend or wake up from suspend
- # due to a kernel bug[1].
+ # This fixes an issue with not being able to suspend or wake up from
+ # suspend due to a kernel bug[1] which is still not fixed.
+ #
+ # I guess this can also be fixed differently[2], which does look a lot nicer
+ # but I just can't bother.
#
# [1]: https://bbs.archlinux.org/viewtopic.php?id=270964
# [1]: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/522998
# [1]: https://bugs.launchpad.net/ubuntu/+source/pm-utils/+bug/562484/comments/3
# [1]: https://gist.github.com/ioggstream/8f380d398aef989ac455b93b92d42048
+ # [2]: https://linrunner.de/tlp/settings/runtimepm.html
powerDownCommands = "${modprobe} -r xhci_pci";
powerUpCommands = "${modprobe} xhci_pci";
};
@@ -40,7 +46,6 @@ with lib; {
services = {
thinkfan = {
enable = true;
-
settings = {
sensors = [
{
@@ -52,7 +57,7 @@ with lib; {
fans = [{tpacpi = "/proc/acpi/ibm/fan";}];
levels = [
["level auto" 0 50]
- ["level disengaged" 50 32767]
+ ["level disengaged" 50 32767] # This could annoy some people but IDGAF.
];
};
};
@@ -60,23 +65,10 @@ with lib; {
fwupd.enable = true;
};
- boot = {
- initrd = {
- availableKernelModules = [
- "ahci"
- "nvme"
- "sd_mod"
- "usb_storage"
- "usbhid"
- "xhci_pci"
- ];
-
- luks.devices."root" = {
- device = "/dev/disk/by-uuid/c1b46f24-eec0-47d2-a142-75ddfd7bb218";
- allowDiscards = true;
- bypassWorkqueues = true;
- };
- };
+ boot.initrd.luks.devices."root" = {
+ device = "/dev/disk/by-uuid/c1b46f24-eec0-47d2-a142-75ddfd7bb218";
+ allowDiscards = true;
+ bypassWorkqueues = true;
};
fileSystems = {