summaryrefslogtreecommitdiff
path: root/nixosConfigurations/varda/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2022-12-17 16:39:09 +0300
committerAzat Bahawi <azat@bahawi.net>2022-12-17 16:39:09 +0300
commit8f137c28230623259a964484adcf31fe00756594 (patch)
tree82bce6a13fda125087cf6d9dc80aa91d9230d6c4 /nixosConfigurations/varda/default.nix
parent3229e56e0d3620ddc735edcfbbefb167efa3b23f (diff)
2022-12-17
Diffstat (limited to 'nixosConfigurations/varda/default.nix')
-rw-r--r--nixosConfigurations/varda/default.nix62
1 files changed, 62 insertions, 0 deletions
diff --git a/nixosConfigurations/varda/default.nix b/nixosConfigurations/varda/default.nix
new file mode 100644
index 0000000..5e0914e
--- /dev/null
+++ b/nixosConfigurations/varda/default.nix
@@ -0,0 +1,62 @@
+{
+ lib,
+ this,
+ ...
+}:
+with lib; {
+ nixfiles.modules = {
+ wireguard.client.enable = true;
+
+ acme.enable = true;
+
+ games.minecraft.server = {
+ enable = false; # Disabled because no one is playing now.
+ memory = "6G";
+ };
+ };
+
+ boot = {
+ loader = {
+ efi.canTouchEfiVariables = true;
+
+ systemd-boot = {
+ enable = true;
+ configurationLimit = 10;
+ };
+ };
+
+ initrd.availableKernelModules = [
+ "ata_piix"
+ "sd_mod"
+ "sr_mod"
+ "uhci_hcd"
+ "virtio_pci"
+ "virtio_scsi"
+ ];
+ };
+
+ fileSystems = {
+ "/boot" = {
+ device = "/dev/disk/by-uuid/03FD-B6C0";
+ fsType = "vfat";
+ };
+
+ "/" = {
+ device = "/dev/disk/by-uuid/b07e8273-915a-424c-8c55-cdc2bd482f49";
+ fsType = "xfs";
+ options = ["noatime"];
+ };
+ };
+
+ swapDevices = [
+ {
+ device = "/swapfile";
+ size = 4 * 1024;
+ }
+ ];
+
+ zramSwap = {
+ enable = true;
+ memoryPercent = 25;
+ };
+}