summaryrefslogtreecommitdiff
path: root/overlays.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-06-19 13:51:20 +0300
committerAzat Bahawi <azat@bahawi.net>2024-06-19 13:51:20 +0300
commit9eb603b80a3d823acfc20c42f777ea26436ca137 (patch)
treea3038492f6525cf7672bb1fddb3293db0223967e /overlays.nix
parentaca022d4437e7c375bbfe7a7613e734c93700e97 (diff)
2024-06-19
Diffstat (limited to 'overlays.nix')
-rw-r--r--overlays.nix35
1 files changed, 20 insertions, 15 deletions
diff --git a/overlays.nix b/overlays.nix
index 3e01cfc..5b80ae2 100644
--- a/overlays.nix
+++ b/overlays.nix
@@ -77,20 +77,25 @@
})).overrideAttrs
(_: super: { patches = (super.patches or [ ]) ++ [ ./patches/telegram-desktop-no-ads.patch ]; });
- vesktop = prev.vesktop.overrideAttrs (
- _: super: {
- nativeBuildInputs = super.nativeBuildInputs ++ [ final.imagemagick ];
- patches = (super.patches or [ ]) ++ [ ./patches/vesktop-no-anime.patch ];
- postInstall =
- (super.postInstall or "")
- + ''
- rm -rf $out/share/icons/hicolor/*
- for size in 16 24 32 48 64 96; do
- convert -scale $size icon.png $size.png
- install -Dm644 $size.png $out/share/icons/hicolor/''${size}x''${size}/apps/vesktop.png
- done
- '';
- }
- );
+ vesktop =
+ (prev.vesktop.overrideAttrs (
+ _: super: {
+ nativeBuildInputs = super.nativeBuildInputs ++ [ final.imagemagick ];
+ patches = (super.patches or [ ]) ++ [ ./patches/vesktop-no-anime.patch ];
+ postInstall =
+ (super.postInstall or "")
+ + ''
+ rm -rf $out/share/icons/hicolor/*
+ for size in 1024 128 256 32 512 64; do
+ convert -scale $size $src/build/icon.png $size.png
+ install -Dm644 $size.png $out/share/icons/hicolor/''${size}x''${size}/apps/vesktop.png
+ done
+ '';
+ }
+ )).override
+ {
+ withSystemVencord = false;
+ withTTS = false;
+ };
};
}