summaryrefslogtreecommitdiff
path: root/packages/hiccup.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-10-25 01:57:50 +0300
committerAzat Bahawi <azat@bahawi.net>2023-10-25 01:57:50 +0300
commit0741650f125d2877d0ab0d9da15d6d3d229f837d (patch)
tree499f32a421e5d5d035fd22908ec2b73fe62f8e71 /packages/hiccup.nix
parente591de4986b1c80f2529b7ba9b0601900a599276 (diff)
2023-10-25
Diffstat (limited to 'packages/hiccup.nix')
-rw-r--r--packages/hiccup.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/hiccup.nix b/packages/hiccup.nix
new file mode 100644
index 0000000..152a5e9
--- /dev/null
+++ b/packages/hiccup.nix
@@ -0,0 +1,35 @@
+{
+ buildNpmPackage,
+ fetchFromGitHub,
+ lib,
+}:
+buildNpmPackage rec {
+ pname = "hiccup";
+ version = "0.4.3";
+
+ src = fetchFromGitHub {
+ owner = "ashwin-pc";
+ repo = pname;
+ rev = "v${version}";
+ hash = "sha256-JLuXQ4jZHI9wF1fgnnBPH/TaTHJL/zGCSuKc9hy4e28=";
+ };
+
+ npmDepsHash = "sha256-YPj7tzMUh56rJfxOVhye4cK6VS0azA/LiE9DMweGLuw=";
+
+ installPhase = ''
+ runHook preInstall
+
+ mv build $out
+
+ runHook postInstall
+ '';
+
+ CYPRESS_INSTALL_BINARY = "0";
+
+ meta = with lib; {
+ description = "A static start page to get to your most important links";
+ inherit (finalAttrs.src.meta) homepage;
+ license = licenses.mit;
+ maintainers = with maintainers; [azahi];
+ };
+}