about summary refs log tree commit diff
path: root/configurations/eonwe/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configurations/eonwe/default.nix')
-rw-r--r--configurations/eonwe/default.nix67
1 files changed, 21 insertions, 46 deletions
diff --git a/configurations/eonwe/default.nix b/configurations/eonwe/default.nix
index f718135..68cfac4 100644
--- a/configurations/eonwe/default.nix
+++ b/configurations/eonwe/default.nix
@@ -193,34 +193,7 @@ with lib;
     cores = 30;
   };
 
-  # Required[1] for using ZFS kernel modules with "unsupported" kernels.
-  #
-  # [1]: https://github.com/NixOS/nixpkgs/pull/121113#issuecomment-830003344
-  # [1]: https://github.com/NixOS/nixpkgs/pull/230498#issuecomment-1551328615
-  nixpkgs.config.allowBroken = true;
-
   boot = {
-    kernelPackages = pkgs.linuxPackages_xanmod_latest;
-
-    kernelParams = [
-      # Silence benign MCE errors:
-      # ```
-      # mce: [Hardware Error]: CPU 1: Machine Check: 0 Bank 29: ffffffffffffffff
-      # mce: [Hardware Error]: TSC 0 MISC ff1fffffffffffff SYND ffffffffffffffff IPID ffffffffffffffff
-      # mce: [Hardware Error]: PROCESSOR 2:a60f12 TIME 1669988017 SOCKET 0 APIC 2 microcode a601201
-      # ```
-      "mce=nobootlog"
-      # This disables[1] User Mode Instruction Protection (UMIP)[2]. This is
-      # required for some games to run via Wine.
-      #
-      # [1]: https://docs.kernel.org/x86/cpuinfo.html
-      # [2]: https://en.wikichip.org/wiki/x86/umip
-      "clearcpuid=514"
-    ];
-
-    # https://wiki.archlinux.org/title/improving_performance#Watchdogs
-    blacklistedKernelModules = [ "sp5100_tco" ];
-
     # The boot drive is Samsung SSD 980 PRO 2TB.
     initrd.kernelModules = [ "nvme" ];
 
@@ -304,31 +277,28 @@ with lib;
     # [1]: https://github.com/nix-community/impermanence/issues/22
     # [1]: https://github.com/NixOS/nixpkgs/pull/86967#pullrequestreview-667929259
     "/home/${my.username}".neededForBoot = true;
-  };
 
-  systemd.mounts = [
-    {
-      type = "tmpfs";
-      what = "tmpfs";
-      where = "/var/tmp";
-      mountConfig.Options = [
-        "huge=within_size"
-        "mode=1777"
-        "noatime"
-        "nodev"
-        "nosuid"
-        "rw"
-        "size=25%"
+    "/mnt/ydata/music" = {
+      device = "yavanna.shire.net:/export/music";
+      fsType = "nfs";
+      options = [
+        "ro"
+        "noauto"
+        "x-systemd.automount"
+        "x-systemd.idle-timeout=${5 * 60 |> toString}"
       ];
-    }
-  ];
+    };
+  };
 
   zramSwap = {
     enable = true;
-    memoryPercent = 25;
+    memoryPercent = 50;
   };
 
-  my.extraGroups = [ "corectrl" ];
+  my.extraGroups = [
+    "corectrl"
+    config.nixfiles.modules.piracy.group
+  ];
 
   users = {
     users.builder = {
@@ -339,7 +309,12 @@ with lib;
       ];
       useDefaultShell = true;
     };
-    groups.builder = { };
+    groups = {
+      builder = { };
+      piracy = {
+        inherit (config.nixfiles.modules.piracy) gid;
+      };
+    };
   };
 
   nix.settings.trusted-users = [ "builder" ];

Consider giving Nix/NixOS a try! <3