summaryrefslogtreecommitdiff
path: root/configurations/eonwe/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configurations/eonwe/default.nix')
-rw-r--r--configurations/eonwe/default.nix84
1 files changed, 0 insertions, 84 deletions
diff --git a/configurations/eonwe/default.nix b/configurations/eonwe/default.nix
deleted file mode 100644
index c9af8e5..0000000
--- a/configurations/eonwe/default.nix
+++ /dev/null
@@ -1,84 +0,0 @@
-{
- config,
- lib,
- pkgs,
- ...
-}:
-with lib; {
- nixfiles.modules = {
- wireguard.client.enable = true;
-
- syncthing.enable = true;
-
- openssh.server.enable = true;
-
- games = {
- lutris.enable = true;
- steam.enable = true;
- };
- android.enable = true;
- bluetooth.enable = true;
- libvirtd.enable = true;
- qutebrowser.enable = true;
- };
-
- hm.programs = {
- firefox.profiles.default.settings."media.ffmpeg.vaapi.enabled" = true;
-
- mpv.config = {
- hwdec = "vdpau";
- vo = "vdpau";
- profile = "gpu-hq";
- };
- };
-
- networking = {
- interfaces = {
- eth0.useDHCP = true;
- wlan0.useDHCP = true;
- };
-
- networkmanager = {
- enable = true;
- wifi.backend = "iwd";
- };
-
- wireless = {
- enable = false;
- iwd.enable = true;
- userControlled.enable = true;
- allowAuxiliaryImperativeNetworks = true;
- };
- };
-
- boot = {
- initrd.availableKernelModules = ["ahci" "nvme" "sd_mod" "usb_storage" "usbhid" "xhci_pci"];
-
- loader = {
- efi.canTouchEfiVariables = true;
-
- systemd-boot = {
- enable = true;
- configurationLimit = 10;
- };
- };
- };
-
- fileSystems = {
- "/boot" = {
- device = "/dev/disk/by-uuid/FF1E-9CFD";
- fsType = "vfat";
- };
-
- "/" = {
- device = "/dev/disk/by-uuid/20276c1b-7e46-430b-b741-2f4aeb76bc51";
- fsType = "xfs";
- options = ["noatime"];
- };
- };
-
- zramSwap = {
- enable = true;
- memoryPercent = 25;
- };
-}