about summary refs log tree commit diff
path: root/configurations/eonwe/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configurations/eonwe/default.nix')
-rw-r--r--configurations/eonwe/default.nix23
1 files changed, 21 insertions, 2 deletions
diff --git a/configurations/eonwe/default.nix b/configurations/eonwe/default.nix
index 875f737..68cfac4 100644
--- a/configurations/eonwe/default.nix
+++ b/configurations/eonwe/default.nix
@@ -277,6 +277,17 @@ with lib;
     # [1]: https://github.com/nix-community/impermanence/issues/22
     # [1]: https://github.com/NixOS/nixpkgs/pull/86967#pullrequestreview-667929259
     "/home/${my.username}".neededForBoot = true;
+
+    "/mnt/ydata/music" = {
+      device = "yavanna.shire.net:/export/music";
+      fsType = "nfs";
+      options = [
+        "ro"
+        "noauto"
+        "x-systemd.automount"
+        "x-systemd.idle-timeout=${5 * 60 |> toString}"
+      ];
+    };
   };
 
   zramSwap = {
@@ -284,7 +295,10 @@ with lib;
     memoryPercent = 50;
   };
 
-  my.extraGroups = [ "corectrl" ];
+  my.extraGroups = [
+    "corectrl"
+    config.nixfiles.modules.piracy.group
+  ];
 
   users = {
     users.builder = {
@@ -295,7 +309,12 @@ with lib;
       ];
       useDefaultShell = true;
     };
-    groups.builder = { };
+    groups = {
+      builder = { };
+      piracy = {
+        inherit (config.nixfiles.modules.piracy) gid;
+      };
+    };
   };
 
   nix.settings.trusted-users = [ "builder" ];

Consider giving Nix/NixOS a try! <3