summaryrefslogtreecommitdiff
path: root/configurations/eonwe/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configurations/eonwe/default.nix')
-rw-r--r--configurations/eonwe/default.nix19
1 files changed, 18 insertions, 1 deletions
diff --git a/configurations/eonwe/default.nix b/configurations/eonwe/default.nix
index ca20140..29f1adc 100644
--- a/configurations/eonwe/default.nix
+++ b/configurations/eonwe/default.nix
@@ -15,7 +15,10 @@ with lib;
syncthing.enable = true;
- openssh.server.enable = true;
+ openssh.server = {
+ enable = true;
+ port = 22;
+ };
android.enable = true;
beets.enable = true;
@@ -294,4 +297,18 @@ with lib;
enable = true;
memoryPercent = 25;
};
+
+ users = {
+ users.builder = {
+ isSystemUser = true;
+ group = "builder";
+ openssh.authorizedKeys.keys = [
+ "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIHzclJfd2n0POaFlYuSRK40JddtS+PYIpFyTz2BY94Wb root@ilmare"
+ ];
+ useDefaultShell = true;
+ };
+ groups.builder = { };
+ };
+
+ nix.settings.trusted-users = [ "builder" ];
}