about summary refs log tree commit diff
path: root/configurations/eonwe/ollama.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configurations/eonwe/ollama.nix')
-rw-r--r--configurations/eonwe/ollama.nix26
1 files changed, 2 insertions, 24 deletions
diff --git a/configurations/eonwe/ollama.nix b/configurations/eonwe/ollama.nix
index 806885b..45e6179 100644
--- a/configurations/eonwe/ollama.nix
+++ b/configurations/eonwe/ollama.nix
@@ -1,11 +1,11 @@
 {
-  config,
   lib,
   ...
 }:
 {
   ark.directories = [
-    config.services.ollama.home
+    "/var/lib/private/open-webui"
+    "/var/lib/private/ollama"
   ];
 
   hm.programs.firefox.profiles.default.bookmarks = [
@@ -32,9 +32,6 @@
       host = "0.0.0.0";
       port = 11434;
 
-      user = "ollama";
-      group = "ollama";
-
       acceleration = "rocm";
       rocmOverrideGfx = "11.0.0";
 
@@ -75,23 +72,4 @@
       openFirewall = true;
     };
   };
-
-  systemd.services.ollama.serviceConfig = {
-    StateDirectory = lib.mkForce config.services.ollama.home;
-    DynamicUser = lib.mkForce false;
-    User = config.services.ollama.user;
-    Group = config.services.ollama.group;
-  };
-
-  users = {
-    users.ollama = {
-      isSystemUser = true;
-      group = "ollama";
-      inherit (config.services.ollama) home;
-      uid = 241; # Reuses a removed ID from Nixpkgs.
-    };
-    groups.ollama.gid = 241;
-  };
-
-  my.extraGroups = [ "ollama" ];
 }

Consider giving Nix/NixOS a try! <3