about summary refs log tree commit diff
path: root/configurations/eonwe/ollama.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configurations/eonwe/ollama.nix')
-rw-r--r--configurations/eonwe/ollama.nix22
1 files changed, 19 insertions, 3 deletions
diff --git a/configurations/eonwe/ollama.nix b/configurations/eonwe/ollama.nix
index a98fb3f..69fa9fd 100644
--- a/configurations/eonwe/ollama.nix
+++ b/configurations/eonwe/ollama.nix
@@ -5,7 +5,9 @@
 }:
 
 {
-  ark.directories = [ config.services.ollama.home ];
+  ark.directories = [
+    config.services.ollama.home
+  ];
 
   hm.programs.firefox.profiles.default.bookmarks = [
     {
@@ -22,7 +24,7 @@
 
   services = {
     ollama = {
-      enable = true;
+      enable = false;
 
       host = "0.0.0.0";
       port = 11434;
@@ -43,8 +45,22 @@
       openFirewall = true;
     };
 
+    open-webui = {
+      enable = false;
+      port = 11436;
+      environment = {
+        ANONYMIZED_TELEMETRY = "False";
+        DO_NOT_TRACK = "True";
+        ENABLE_SIGNUP = "False";
+        OLLAMA_BASE_URL = "http://127.0.0.1:11434";
+        SCARF_NO_ANALYTICS = "True";
+        WEBUI_AUTH = "False";
+        WEBUI_URL = "http://eonwe.shire.net:11436";
+      };
+    };
+
     nextjs-ollama-llm-ui = {
-      enable = true;
+      enable = false;
 
       hostname = "0.0.0.0";
       port = 11435;

Consider giving Nix/NixOS a try! <3