summaryrefslogtreecommitdiff
path: root/configurations/ilmare/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configurations/ilmare/default.nix')
-rw-r--r--configurations/ilmare/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/configurations/ilmare/default.nix b/configurations/ilmare/default.nix
index 1e9f5ff..a1b5007 100644
--- a/configurations/ilmare/default.nix
+++ b/configurations/ilmare/default.nix
@@ -123,4 +123,28 @@ _: {
enable = true;
memoryPercent = 100;
};
+
+ nix = {
+ buildMachines = [
+ {
+ hostName = "eonwe.shire.net";
+
+ protocol = "ssh-ng";
+ sshUser = "builder";
+ sshKey = "/root/.ssh/id_ed25519";
+
+ system = "x86_64-linux";
+ supportedFeatures = [
+ "nixos-test"
+ "benchmark"
+ "big-parallel"
+ "kvm"
+ ];
+ }
+ ];
+
+ distributedBuilds = true;
+
+ settings.builders-use-substitutes = true;
+ };
}