about summary refs log tree commit diff
path: root/configurations/manwe/webserver.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configurations/manwe/webserver.nix')
-rw-r--r--configurations/manwe/webserver.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/configurations/manwe/webserver.nix b/configurations/manwe/webserver.nix
index 051ddba..6f6061e 100644
--- a/configurations/manwe/webserver.nix
+++ b/configurations/manwe/webserver.nix
@@ -5,12 +5,11 @@
   libPlausible,
   ...
 }:
-with lib;
 {
   nixfiles.modules.nginx = {
     enable = true;
     virtualHosts =
-      with my.domain;
+      with lib.my.domain;
       {
         ${shire}.locations."/".return = "301 https://www.youtube.com/watch?v=dQw4w9WgXcQ";
         "git.${shire}".locations."/".return = "301 https://git.${azahi}";
@@ -31,11 +30,11 @@ with lib;
           frodo = "301 https://frodo.";
         in
         {
-          ${gondor}.locations."/".return = concatStrings [
+          ${gondor}.locations."/".return = lib.concatStrings [
             frodo
             gondor
           ];
-          ${rohan}.locations."/".return = concatStrings [
+          ${rohan}.locations."/".return = lib.concatStrings [
             frodo
             rohan
           ];

Consider giving Nix/NixOS a try! <3