summaryrefslogtreecommitdiff
path: root/configurations/manwe/webserver.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configurations/manwe/webserver.nix')
-rw-r--r--configurations/manwe/webserver.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/configurations/manwe/webserver.nix b/configurations/manwe/webserver.nix
new file mode 100644
index 0000000..fd23432
--- /dev/null
+++ b/configurations/manwe/webserver.nix
@@ -0,0 +1,21 @@
+{
+ inputs,
+ lib,
+ ...
+}:
+with lib; {
+ config.nixfiles.modules.nginx.virtualHosts = with my.domain;
+ {
+ ${shire}.locations."/".return = "301 https://www.youtube.com/watch?v=dQw4w9WgXcQ";
+ ${azahi} = {
+ serverAliases = ["frodo.${gondor}" "frodo.${rohan}"];
+ locations."/".root = inputs.azahi-cc;
+ };
+ }
+ // (let
+ frodo = "301 https://frodo.";
+ in {
+ ${gondor}.locations."/".return = concatStrings [frodo gondor];
+ ${rohan}.locations."/".return = concatStrings [frodo rohan];
+ });
+}