summaryrefslogtreecommitdiff
path: root/configurations/test-headful/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configurations/test-headful/default.nix')
-rw-r--r--configurations/test-headful/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/configurations/test-headful/default.nix b/configurations/test-headful/default.nix
new file mode 100644
index 0000000..fb3c276
--- /dev/null
+++ b/configurations/test-headful/default.nix
@@ -0,0 +1,27 @@
+{
+ lib,
+ modulesPath,
+ ...
+}:
+with lib; {
+ imports = ["${modulesPath}/profiles/qemu-guest.nix"];
+
+ nixfiles.modules = {
+ dwm.enable = true;
+ kde.enable = false;
+ xmonad.enable = false;
+ };
+
+ boot.loader.systemd-boot.enable = true;
+ fileSystems."/".device = "/dev/null";
+
+ documentation = {
+ enable = mkForce false;
+ man = {
+ enable = mkForce false;
+ man-db.enable = mkForce false;
+ };
+ };
+
+ system.stateVersion = "22.05";
+}