summaryrefslogtreecommitdiff
path: root/configurations/varda/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configurations/varda/default.nix')
-rw-r--r--configurations/varda/default.nix62
1 files changed, 0 insertions, 62 deletions
diff --git a/configurations/varda/default.nix b/configurations/varda/default.nix
deleted file mode 100644
index 5e0914e..0000000
--- a/configurations/varda/default.nix
+++ /dev/null
@@ -1,62 +0,0 @@
-{
- lib,
- this,
- ...
-}:
-with lib; {
- nixfiles.modules = {
- wireguard.client.enable = true;
-
- acme.enable = true;
-
- games.minecraft.server = {
- enable = false; # Disabled because no one is playing now.
- memory = "6G";
- };
- };
-
- boot = {
- loader = {
- efi.canTouchEfiVariables = true;
-
- systemd-boot = {
- enable = true;
- configurationLimit = 10;
- };
- };
-
- initrd.availableKernelModules = [
- "ata_piix"
- "sd_mod"
- "sr_mod"
- "uhci_hcd"
- "virtio_pci"
- "virtio_scsi"
- ];
- };
-
- fileSystems = {
- "/boot" = {
- device = "/dev/disk/by-uuid/03FD-B6C0";
- fsType = "vfat";
- };
-
- "/" = {
- device = "/dev/disk/by-uuid/b07e8273-915a-424c-8c55-cdc2bd482f49";
- fsType = "xfs";
- options = ["noatime"];
- };
- };
-
- swapDevices = [
- {
- device = "/swapfile";
- size = 4 * 1024;
- }
- ];
-
- zramSwap = {
- enable = true;
- memoryPercent = 25;
- };
-}