summaryrefslogtreecommitdiff
path: root/darwinConfigurations/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'darwinConfigurations/default.nix')
-rw-r--r--darwinConfigurations/default.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/darwinConfigurations/default.nix b/darwinConfigurations/default.nix
new file mode 100644
index 0000000..612c8b0
--- /dev/null
+++ b/darwinConfigurations/default.nix
@@ -0,0 +1,35 @@
+{
+ inputs,
+ lib,
+}:
+with lib; let
+ mkConfiguration = name: {
+ modules ? [],
+ configuration ? ./${name},
+ this ? my.configurations.${name},
+ extraSpecialArgs ? {
+ localUsername = my.username;
+ localHostname = this.hostname;
+ },
+ }:
+ nameValuePair name (inputs.darwin.lib.darwinSystem {
+ inherit (this) system;
+ modules =
+ modules
+ ++ attrValues inputs.self.modules
+ ++ attrValues inputs.self.darwinModules
+ ++ optional (configuration != null) (import configuration);
+ specialArgs =
+ {
+ inherit inputs lib this;
+ }
+ // extraSpecialArgs;
+ });
+in
+ mapAttrs' mkConfiguration {
+ mairon.extraSpecialArgs = {
+ # These values are managed by my employer.
+ localUsername = "username";
+ localHostname = "hostname";
+ };
+ }