summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 5fd0fb5..68f66d2 100644
--- a/flake.nix
+++ b/flake.nix
@@ -259,8 +259,14 @@
inherit (self.checks.${system}.preCommit) shellHook;
};
- # Very opinionated but works fast and doesn't get in a way like nixfmt.
- formatter = pkgs.alejandra;
+ # This interface is very primitive...
+ formatter = pkgs.writeShellApplication {
+ name = "fmt";
+ runtimeInputs = with pkgs; [alejandra];
+ text = ''
+ alejandra --quiet "$@"
+ '';
+ };
checks.preCommit = pre-commit-hooks.lib.${system}.run {
src = ./.;