summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix16
1 files changed, 5 insertions, 11 deletions
diff --git a/flake.nix b/flake.nix
index 1019a60..727ba2f 100644
--- a/flake.nix
+++ b/flake.nix
@@ -120,14 +120,6 @@
flake = false;
};
- xmonad-ng = {
- url = "git+https://git.azahi.cc/xmonad-ng?ref=master";
- inputs = {
- nixpkgs.follows = "nixpkgs";
- flake-utils.follows = "flake-utils";
- };
- };
-
azahi-cc = {
url = "git+https://git.azahi.cc/azahi-cc?ref=master";
flake = false;
@@ -182,9 +174,11 @@
default = self.packages.${system}.nixfiles;
inherit (self.legacyPackages.${system}) nixfiles;
- iso = self.nixosConfigurations.iso.config.system.build.isoImage;
-
topology = self.topology.config.output;
+
+ iso = self.nixosConfigurations.iso.config.system.build.isoImage;
+ test-headless = self.nixosConfigurations.test-headless.config.system.build.vm;
+ test-headful = self.nixosConfigurations.test-headful.config.system.build.vm;
};
legacyPackages.${system} = pkgs;
@@ -194,7 +188,7 @@
devShells.${system}.default =
with pkgs;
mkShell {
- inherit (self.checks.${system}.preCommit) shellHook;
+ inherit (self.checks.${system}.git-hooks) shellHook;
packages = [ go-task ];
};