summaryrefslogtreecommitdiff
path: root/lib/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/default.nix')
-rw-r--r--lib/default.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/lib/default.nix b/lib/default.nix
index 6517125..d121f5e 100644
--- a/lib/default.nix
+++ b/lib/default.nix
@@ -28,5 +28,13 @@ lib: _: rec {
mkTcpMem = min: ini: max:
assert min <= ini && ini <= max;
- builtins.concatMapStrings (x: toString x + " ") (map (pow 2) [min ini max]);
+ lib.concatMapStrings (x: toString x + " ") (map (pow 2) [min ini max]);
+
+ # TODO Move this somehow to the NGINX module itself.
+ nginxInternalOnly = ''
+ if ($internal != 1) {
+ return 403;
+ }
+ access_log off;
+ '';
}