summaryrefslogtreecommitdiff
path: root/lib/dns.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/dns.nix')
-rw-r--r--lib/dns.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/lib/dns.nix b/lib/dns.nix
new file mode 100644
index 0000000..e486f1c
--- /dev/null
+++ b/lib/dns.nix
@@ -0,0 +1,14 @@
+_: {
+ const = {
+ quad9 = {
+ default = ["9.9.9.9" "149.112.112.112" "2620:fe::fe" "2620:fe::9"];
+ unsecured = ["9.9.9.10" "149.112.112.10" "2620:fe::10" "2620:fe::fe:10"];
+ ecs = ["9.9.9.11" "149.112.112.11" "2620:fe::11" "2620:fe::fe:11"];
+ };
+ cloudflare = {
+ default = ["1.1.1.1" "1.0.0.1" "2606:4700:4700::1111" "2606:4700:4700::1001"];
+ blocking = ["1.1.1.2" "1.0.0.2" "2606:4700:4700::1112" "2606:4700:4700::1002"];
+ blockingPlus = ["1.1.1.3" "1.0.0.3" "2606:4700:4700::1113" "2606:4700:4700::1003"];
+ };
+ };
+}