summaryrefslogtreecommitdiff
path: root/modules/android.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/android.nix')
-rw-r--r--modules/android.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/modules/android.nix b/modules/android.nix
new file mode 100644
index 0000000..363bd6c
--- /dev/null
+++ b/modules/android.nix
@@ -0,0 +1,14 @@
+{ config, lib, ... }:
+with lib;
+let
+ cfg = config.nixfiles.modules.android;
+in
+{
+ options.nixfiles.modules.android.enable = mkEnableOption "support for Android devices";
+
+ config = mkIf cfg.enable {
+ programs.adb.enable = true;
+
+ my.extraGroups = [ "adbusers" ];
+ };
+}