summaryrefslogtreecommitdiff
path: root/modules/common/aria2.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/aria2.nix')
-rw-r--r--modules/common/aria2.nix33
1 files changed, 0 insertions, 33 deletions
diff --git a/modules/common/aria2.nix b/modules/common/aria2.nix
deleted file mode 100644
index cdf1c4f..0000000
--- a/modules/common/aria2.nix
+++ /dev/null
@@ -1,33 +0,0 @@
-{ config, lib, ... }:
-with lib;
-let
- cfg = config.nixfiles.modules.aria2;
-in
-{
- options.nixfiles.modules.aria2.enable = mkEnableOption "aria2";
-
- config = mkIf cfg.enable {
- hm.programs.aria2 = {
- enable = true;
-
- settings = {
- bt-max-peers = 128;
- bt-save-metadata = true;
- continue = true;
- enable-dht = true;
- enable-peer-exchange = true;
- enable-rpc = false;
- follow-torrent = true;
- log-level = "info";
- max-connection-per-server = 16;
- max-overall-upload-limit = "1K";
- max-tries = 5;
- max-upload-limit = "1K";
- seed-ratio = 0.1;
- seed-time = 0.1;
- stream-piece-selector = "default";
- timeout = 60;
- };
- };
- };
-}