summaryrefslogtreecommitdiff
path: root/modules/common/bat.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/bat.nix')
-rw-r--r--modules/common/bat.nix26
1 files changed, 0 insertions, 26 deletions
diff --git a/modules/common/bat.nix b/modules/common/bat.nix
deleted file mode 100644
index a95d67d..0000000
--- a/modules/common/bat.nix
+++ /dev/null
@@ -1,26 +0,0 @@
-{ config, lib, ... }:
-with lib;
-let
- cfg = config.nixfiles.modules.bat;
-in
-{
- options.nixfiles.modules.bat.enable = mkEnableOption "bat, an alternative to cat";
-
- config = mkIf cfg.enable {
- nixfiles.modules.common.shell.aliases = {
- baj = "bat --language=json --tabs 2";
- bay = "bat --language=yaml --tabs 2";
- bas = "bat --language=syslog";
- less = "bat";
- };
-
- hm.programs.bat = {
- enable = true;
- config = {
- style = "plain";
- tabs = "4";
- wrap = "never";
- };
- };
- };
-}