summaryrefslogtreecommitdiff
path: root/modules/common/common/stylix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/common/stylix.nix')
-rw-r--r--modules/common/common/stylix.nix61
1 files changed, 0 insertions, 61 deletions
diff --git a/modules/common/common/stylix.nix b/modules/common/common/stylix.nix
deleted file mode 100644
index f1b8f81..0000000
--- a/modules/common/common/stylix.nix
+++ /dev/null
@@ -1,61 +0,0 @@
-{ lib, pkgs, ... }:
-with lib;
-{
- imports = [
- (mkAliasOptionModule [ "colors" ] [
- "lib"
- "stylix"
- "colors"
- ])
- ];
-
- options.nixfiles.modules.common.stylix.fonts.extraPackages = mkOption {
- description = "Font packages.";
- default = with pkgs; [
- font-awesome
- noto-fonts
- noto-fonts-emoji
- sarasa-gothic
- source-han-mono
- source-han-sans
- source-han-serif
- twitter-color-emoji
- ];
- readOnly = true;
- };
-
- # Styling and color binding can be sourced from here[1].
- #
- # [1]: https://github.com/tinted-theming/base24/blob/master/styling.md
- config.stylix = {
- image = pkgs.fetchurl {
- url = "https://upload.wikimedia.org/wikipedia/commons/a/a5/Bonaparte_ante_la_Esfinge%2C_por_Jean-Léon_Gérôme.jpg";
- sha256 = "sha256-qWv52oT8cF9K4ZoeawmR3jgoGB2ARfjbKKc12IljUcM=";
- };
-
- base16Scheme = "${pkgs.base16-schemes}/share/themes/tomorrow.yaml";
-
- fonts = {
- monospace = {
- package = pkgs.iosevka;
- name = "Iosevka";
- };
-
- serif = {
- package = pkgs.iosevka-bin.override { variant = "Etoile"; };
- name = "Iosevka Etoile";
- };
-
- sansSerif = {
- package = pkgs.iosevka-bin.override { variant = "Aile"; };
- name = "Iosevka Aile";
- };
-
- sizes = {
- desktop = 10;
- applications = 10;
- terminal = 12;
- };
- };
- };
-}