summaryrefslogtreecommitdiff
path: root/modules/common/curl.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/curl.nix')
-rw-r--r--modules/common/curl.nix38
1 files changed, 0 insertions, 38 deletions
diff --git a/modules/common/curl.nix b/modules/common/curl.nix
deleted file mode 100644
index 6895262..0000000
--- a/modules/common/curl.nix
+++ /dev/null
@@ -1,38 +0,0 @@
-{
- config,
- lib,
- pkgs,
- ...
-}:
-with lib;
-let
- cfg = config.nixfiles.modules.curl;
-in
-{
- options.nixfiles.modules.curl.enable = mkEnableOption "cURL";
-
- config = mkIf cfg.enable {
- hm.xdg.configFile.".curlrc".text = ''
- connect-timeout = 60
- progress-bar
- remote-time
- show-error
- '';
-
- environment.systemPackages = with pkgs; [
- curl
- (writeShellScriptBin "0x0" ''
- url="https://0x0.st"
- form="file=@"
-
- if [ -t 0 ] && [ -n "$1" ]; then
- form="$form$1"
- else
- form="$form-"
- fi
-
- ${getExe curl} --form "$form" "$url"
- '')
- ];
- };
-}