summaryrefslogtreecommitdiff
path: root/modules/common/direnv.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/direnv.nix')
-rw-r--r--modules/common/direnv.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/modules/common/direnv.nix b/modules/common/direnv.nix
index b235cee..6ec39d1 100644
--- a/modules/common/direnv.nix
+++ b/modules/common/direnv.nix
@@ -10,13 +10,13 @@ in {
mkEnableOption "direnv";
config = mkIf cfg.enable {
- hm = {
- programs.direnv = {
- enable = true;
- nix-direnv.enable = true;
+ hm.programs.direnv = {
+ enable = true;
+ config.global = {
+ strict_env = true;
+ warn_timeout = 0;
};
-
- home.sessionVariables.DIRENV_LOG_FORMAT = "";
+ nix-direnv.enable = true;
};
};
}