summaryrefslogtreecommitdiff
path: root/modules/common/direnv.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/direnv.nix')
-rw-r--r--modules/common/direnv.nix23
1 files changed, 0 insertions, 23 deletions
diff --git a/modules/common/direnv.nix b/modules/common/direnv.nix
deleted file mode 100644
index ececad8..0000000
--- a/modules/common/direnv.nix
+++ /dev/null
@@ -1,23 +0,0 @@
-{ config, lib, ... }:
-with lib;
-let
- cfg = config.nixfiles.modules.direnv;
-in
-{
- options.nixfiles.modules.direnv.enable = mkEnableOption "direnv";
-
- config = mkIf cfg.enable {
- hm = {
- home.sessionVariables.DIRENV_LOG_FORMAT = "";
-
- programs.direnv = {
- enable = true;
- config.global = {
- strict_env = true;
- warn_timeout = "1h";
- };
- nix-direnv.enable = true;
- };
- };
- };
-}